Visit the main Crossref website

Submission was not successful! The DOI registration server returned an error

Hello Sir / Madam,
I am facing a problem when submit DOI from Crossref Export Plugin (OJS-3.1.1.4). Showing this below error.

Please see the screenshot.

OJS Version- 3.1.1.4
PHP Version- 7.3

Submission was not successful! The DOI registration server returned an error: '1 - HTTP/1.1 100 Continue HTTP/1.1 400 Bad Request server: Apache-Coyote/1.1 crossref-deployment-name: ds5-2 content-length: 0 date: Mon, 14 Jun 2021 05:02:21 GMT permissions-policy: interest-cohort=() connection: close

Please help me.

Regards,
Surojit Bera

Hi,@surojitbera2

Could you send me the xml so I can try to identify the error?

1 Like

Hello,

Please see the attached xml file.
crossref-20210614-045613-articles-126.xml (5.4 KB)

Hello @abec
Just now I am uploading this xml through Crossref Administration Console is successfully submitted without any problem.

Hi @surojitbera2

There is no error in you xml file.
Have you tried to upload this file via https://0-doi-crossref-org.library.alliant.edu/servlet/useragent ?
You have to login with your username and password and click upload.

hi @abec
Yes… I am uploading this xml via https://0-doi-crossref-org.library.alliant.edu/servlet/useragent is successfully submitted without any problem.

So I think the username and password in the OJS might be wrong or the server might be blocking access to Crossref.

every thing is okay. I put right username & password

I am facing this problem last 5 days. My OJS version 3.1.1.4. Already I post this same problem in https://forum.pkp.sfu.ca/.

I received this message from pkp forum

Here is posts of users encountering similar errors here and addressing them here (though verifying their crossref credentials): CrossRef XML Explort Plugin - DOI Submission error - #2 by bozana

Perhaps you could try that and let me know if it works?

And, just a note, that the version of OJS that you’re using (3.1) is no longer supported by PKP. I recommend that you upgrade to the newest version of OJS, as there are some improvements in OJS and the Crossref plugins that you may wish to take advantage of. Along with that, you may wish to upgrade your Crossref plugin.

Upgrading instructions are available in the PKP Administrator’s Guide .

Information about the latest version of OJS can be found on the [PKP Website]https://pkp.sfu.ca/ojs/

The Crossref documentation can be found here: Crossref OJS 3.2+ Manual